Partagez
Aller en bas
avatar
Kingdommangas
Membre

Nombre de messages : 1168
Localisation : Ma tête
Distinction : Débrouillarde notoire é_è [Mist']
Ou celle qui partageait plus vite que son ombre [Gel']
Poisson 2017 [Amal]
Grâce à elle, tout le forum appelle Yamashi "Mamashi" [Yama]
Entraide d'Or
Règne dans l'ombre de la commu'
Youtubeuse beauté reconvertie dans le gaming [Amal']
Date d'inscription : 05/05/2015
https://www.youtube.com/channel/UCqGFuGrzm7jim1o5QJ4lKvg

Equipement avec un niv minimum requis

le Mer 8 Juin 2016 - 17:48
Pour l'utilisation, il suffit de définir quel est le niveau requis en note sur l'item. Il vaut mieux préciser le niveau requis en dans la définition de l'item.



Code:
# =============================================================================
# TheoAllen - Minimum Level Equip Requirement
# Version : 1.0c
# Contact : www.rpgmakerid.com (or) <a href="http://theolized.blogspot.com" target="_blank">http://theolized.blogspot.com</a>
# (This script documentation is written in informal indonesian language)
# =============================================================================
($imported ||= {})[:Theo_MinLevelEquip] = true
# =============================================================================
# CHANGE LOGS:
# -----------------------------------------------------------------------------
# 2013.09.21 - Bug fix when optimizing equip
# 2013.08.10 - Bug fix when unequip item
# 2013.08.05 - Finished script
# =============================================================================
=begin
 
  Perkenalan :
  Script ini ngebikin setiap equip bisa disetting level minimalnya buat
  digunain
 
  Cara penggunaan :
  Pasang dibawah material namun diatas main
  Gunakan notetag <min level: n> pada note equip. Dimana n adalah level minimal
  yang dibutuhkan untuk diequip
 
  Terms of Use :
  Credit gw, TheoAllen. Kalo semisal u bisa ngedit2 script gw trus jadi lebih
  keren, terserah. Ane bebasin. Asal ngga ngeklaim aja. Kalo semisal mau
  dipake buat komersil, jangan lupa, gw dibagi gratisannya.
 
  Utilisation:
  ecrire <min level: n> en note sur l'équipement.(a écrire aussi dans la définition pour le joueur)
  ex: <min level: 10>
 
=end
# =============================================================================
# Tidak ada konfigurasi
# =============================================================================
class << DataManager
 
  alias theo_equip_level_load_db load_database
  def load_database
    theo_equip_level_load_db
    load_equip_minimum_level
  end
 
  def load_equip_minimum_level
    ($data_armors + $data_weapons).compact.each do |equip|
      equip.load_minimum_level_req
    end
  end
 
end
 
class RPG::EquipItem < RPG::BaseItem
  attr_accessor :minimum_level
 
  def load_minimum_level_req
    @minimum_level = 1
    self.note.split(/[\r\n]+/).each do |line|
      case line
      when /<(?:MIN_LEVEL|min level): [ ]*(\d+)>/i
        @minimum_level = $1.to_i
      end
    end
  end
 
end
 
class Window_EquipItem < Window_ItemList
 
  alias theo_min_equip_level_enable? enable?
  def enable?(item)
    return theo_min_equip_level_enable?(item) && sufficient_level?(item)
  end
 
  def sufficient_level?(item)
    return true unless item
    return @actor.level >= item.minimum_level
  end
 
end
 
class Game_Actor < Game_Battler
  #--------------------------------------------------------------------------
  # Overwrite Optimize Equipment
  #--------------------------------------------------------------------------
  def optimize_equipments
    clear_equipments
    equip_slots.size.times do |i|
      next if !equip_change_ok?(i)
      items = $game_party.equip_items.select do |item|
        item.etype_id == equip_slots[i] &&
        equippable?(item) && item.performance >= 0 &&
        sufficient_equip_level?(item)
      end
      change_equip(i, items.max_by {|item| item.performance })
    end
  end
 
  def sufficient_equip_level?(item)
    level >= item.minimum_level
  end
end

Source -> http://www.theolized.com/2013/08/theo-minimum-level-equip-requirement.html
avatar
Coco'
Staffeux retraité

Nombre de messages : 6575
Age : 24
Localisation : Nord/Douai
Distinction : EL DICTATOR COCO'
Coco-Dieu en puissance

Grand gourou suppléant de la secte des MAGIKARP
Leader charismatique des 2beStaffieux

N°1 du forum
Président, vice-présidents et membres honoraires de la cour suprême du forum
Président de l'association des grosses distinctions CMB
Date d'inscription : 02/07/2008
http://www.rpgmakervx-fr.com

Re: Equipement avec un niv minimum requis

le Mer 8 Juin 2016 - 22:58
Ça fait 20 ans que les gens demandent ça sur RPG Maker (je le voulais sur mes vieux projets sur RPG Maker XP, ça me rajeunit pas), et Enterbrain est pas foutu de l'avoir inséré de base, c'est fou XD


Merci du partage !
avatar
Shinokishi
Membre

Nombre de messages : 519
Age : 18
Localisation : Quelque part en France (mais je sais pas où)
Distinction : Message-minute (Spy)
Date d'inscription : 23/08/2015

Re: Equipement avec un niv minimum requis

le Dim 12 Juin 2016 - 9:16
rooooh t'es pas si vieux coco' (t'es juste un peu plus vieux que Spy' XD)

merci du partage Kingdom' Smile
Contenu sponsorisé

Re: Equipement avec un niv minimum requis

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum