Partagez
Aller en bas
avatar
Molulu
Membre

Nombre de messages : 10
Date d'inscription : 13/07/2010

[Résolu] Problème avec le script Enduits

le Ven 16 Juil 2010 - 9:10
Bonjour, chère communauté
il se trouve que lorsque j'ouvre le menu enduits je reçois ce message d'erreur : Script 'enduit' line 672: Type Error occurred
cannot convert nil into String
Pourquoi? Comment puis-je y remédier? Merci d'avance.


Dernière édition par Molulu le Ven 16 Juil 2010 - 12:43, édité 1 fois
avatar
dricc
Membre

Nombre de messages : 2756
Localisation : Lille
Distinction : Altruiste - Incarnation de la Patience [Mist']
Date d'inscription : 10/08/2009

Re: [Résolu] Problème avec le script Enduits

le Ven 16 Juil 2010 - 12:08
Bonjour aussi Smile

T'as pas posté au bon endroit ...
Et merci de nous donner :
- Le lien vers le script
- La ligne de code en question

Pour moi , c'est un probleme de paramétrage du script . Comme beaucoup de script , quand tu te trompes dans le paramétrage , ça te donne pas une erreur claire . Je pense en l'occurence que tu as du définir des enduits sans rien leur mettre de zone commentaire . Alors mon conseil : revoit TOUT le paramétrage .
avatar
Molulu
Membre

Nombre de messages : 10
Date d'inscription : 13/07/2010

Re: [Résolu] Problème avec le script Enduits

le Ven 16 Juil 2010 - 12:13
Alors là est le lien du script :
http://www.rpgmakervx-fr.com/combats-f185/enduits-pour-lames-t4560.htm?highlight=enduits
La ligne qui bloque:
self.contents.draw_text(0,20,400,WLH,"Effet : " + type_bonus +" + " + bonus.to_s )
Le message d'erreur:
Script 'enduit' line 672: Type Error occurred
cannot convert nil into String
avatar
dricc
Membre

Nombre de messages : 2756
Localisation : Lille
Distinction : Altruiste - Incarnation de la Patience [Mist']
Date d'inscription : 10/08/2009

Re: [Résolu] Problème avec le script Enduits

le Ven 16 Juil 2010 - 12:22
ok , alors vu le message , l'erreur est dans "bonus.to_s" .
En gros , il s'attend à ce que "bonus" soit une chaine de caractere alors que c'est une valeur nulle .

Ce qui signifie bien que l'enduit que le script essaye de d'afficher est mal paramétré , il n'a pas de bonus défini .
Donc , je te confirme : revois tout ton paramétrage !
retrouve quels sont tout tes enduits (avec un tableau appelé ENDUITS) et vérifie que tous ont qq chose dans la zone "Commentaires" (et que ce soit correct , bien sur , attention aux "=" : pas d'espaces ni devant ni derriere)

Et pour le script , je sais qu'on le retrouve par une simple recherche mais vois-tu quand on demande de l'aide , il faut donner un maximum d'infos pour que celui qui veux t'aider n'ait pas à chercher .
avatar
Molulu
Membre

Nombre de messages : 10
Date d'inscription : 13/07/2010

Re: [Résolu] Problème avec le script Enduits

le Ven 16 Juil 2010 - 12:23
Ok merci si c'est bon je mets "Résolu", réponse rapide Very Happy

EDIT :Arff ça ne marche toujours pas; même message d'erreur; j'ai vérifié tous mes Enduits , leurs commentaires..;

EDIT: Alléluja! J'ai trouvé! L'erreur se trouvait bel et bien dans les commentaires: j'avais écrit TypeBonus au lieu de Typebonus! Merci! Mais comment on fait pour mettre Résolu? ^^
avatar
Dudu'
Staffeux retraité

Nombre de messages : 2060
Age : 27
Distinction : Apprenti KGB-boy en avenir
[Coco' Smile]
Hamsterphile de service ^^
[Balby' le Fake]
Grand prof de la MA
[Skillo]
Ce grand programmateur, mon coeur, ma vie ! [Hamu']
Date d'inscription : 22/06/2009

Re: [Résolu] Problème avec le script Enduits

le Ven 16 Juil 2010 - 13:21
tu édite le premier message
avatar
Invité
Invité

Re: [Résolu] Problème avec le script Enduits

le Ven 16 Juil 2010 - 20:16
Attention aux doubles posts, c'est signe d'averto ...
Mais bon pour cette fois, je te supprime celui ci et édite le précédent, pense y la prochaine fois Wink
Contenu sponsorisé

Re: [Résolu] Problème avec le script Enduits

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum