Partagez
Aller en bas
avatar
migou
Membre

Nombre de messages : 66
Age : 38
Distinction : aucune
Date d'inscription : 13/06/2009

[résolu] Problème de Lag

le Jeu 4 Fév 2010 - 15:26
Chers membres de la commu', bonjour à toutes, bonjour à tous,


Je suis débutant en making, et j'aurai besoin de votre expérience et de votre avis sur le point suivant;

J'ai crée une map d'une ville de très grande taille (capitale) king ;
Pour compléter les Tiles (je n'utilise pas Tileset editor), j'utilise un nombre important de charaset déléments de décor.
De plus, j'hésite à utiliser des events pour afficher des halos de lumière autour de mes sources lumineuses (lampadaire, bougie, feu...)
J'ai déjà mis en place des events communs pour le cycle jour / nuit.

Bref, en mode test, ma map lag énormément (au contraire de mes petites map dans le même projet). scratch

Est ce que ce lag se retrouvera dans mon jeu une fois compilé? Neutral
Est ce que mon PC est une mule (Intel 2Ghz Double Core, 3 Go de Ram quand même... c'est pas une super famicom de fillette...)? Suspect
Dois je favoriser la mise en place de script pour ma gestion jour / nuit, les sources de lumière? study
Dois je faire le deuil de RMVX et ses 5 Tileset, et me plongé dans Tilset editor (l'impossibilité d'afficher les tileset dans RMVX me parait extrêmement handicapante)?

PS: J'ai vu qu'il existe un lien vers un tuto sur le lag, mais malheureusement, la parefeu de ma boîte me bloque (je sais c'est moche de chatter au taf...)

En attendant de vous lire, cher maker


Dernière édition par migou le Jeu 4 Fév 2010 - 17:01, édité 4 fois
avatar
dricc
Membre

Nombre de messages : 2756
Localisation : Lille
Distinction : Altruiste - Incarnation de la Patience [Mist']
Date d'inscription : 10/08/2009

Re: [résolu] Problème de Lag

le Jeu 4 Fév 2010 - 15:33
Ah oui , il te faut un script antilag .
Fait une recherche , tu trouveras . Y'en a de plus ou moins compliqué ( et plus ou moins efficace) .
avatar
migou
Membre

Nombre de messages : 66
Age : 38
Distinction : aucune
Date d'inscription : 13/06/2009

Re: [résolu] Problème de Lag

le Jeu 4 Fév 2010 - 16:09
Salut dricc,

merci pour ta réponse, en fait, je n'avait pas encore trouvé ce topic (étrangement, en faisant une recherche sur le mot lag, je n'avais jamais de réponse, et puis le mot antilag est entré dans mon vocabulaire, et là... )

Bref, ça me semble être bon. Je fais un test ce soir, car j'ai un petit doute sur le post de widowman
Lorsque certains events de grande taille vous posent des problèmes, insérez le commentaire : Allways_update
Pour les affichages de pictures de grandes tailles inserez en commentaire : large_bitmap

Etant absolument zéro en Ruby, je me demande si insérez le commentaire n'est pas une commande spécifique...

Bref, j'vais me débrouiller.
Comme diraient certains, c'est en makant...

En tout cas merci mille fois. Je passe le topic en [résolu]

Very Happy
Contenu sponsorisé

Re: [résolu] Problème de Lag

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum