Partagez
Aller en bas
Mikem
Mikem
Membre

Nombre de messages : 16
Age : 25
Localisation : Alpes-Maritimes
Distinction : aucune
Date d'inscription : 15/07/2014

Résolu [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mar 23 Aoû 2016 - 11:48
Bonjour/bonsoir

J'ai récemment télécharger un script (Tactical Battle system) pour un de mes projets sur RMXP et en copiant-collant le script, ainsi que tout les composants (Images, animations, etc.) dans mon dossier comme indiqué tout en bas sur ce site : http://www.gdunlimited.net/scripts/rpg-maker-xp/custom-battle-scripts/gtbs-gubid-s-tactical-battle-system, bref j'ai fais ma premier Map à l'image de celle qui est sur le projet ou se trouver le script de base, et donc en lançant mon projet, tout fonctionne normalement mais une fois en jeux, je dirige le character, en direction du monstre pour lancer le combat et après avoir cliquer sur le monstre un message apparaît sur un écran noir me reportant un bug, voici l'image :[Résolu] Bug sur Script TBS (Tactical Battle System) RMXP Messag10

Voici également une image du script nommé Game_Actor où se trouve le bug ligne n°114 :[Résolu] Bug sur Script TBS (Tactical Battle System) RMXP Bugscr10


En espérant que vous pourrez m'aider à trouver la solution à mon problème, je vous remercie par ailleurs pour votre aide et vous souhaite à tous une bonne journée/soirée/nuit.

PS : Pour ceux et celles qui le souhaiterait j'ai teamviewer d'installer, ainsi que dropbox et skype.

Cordialement

Mikem


Dernière édition par Mikem le Lun 29 Aoû 2016 - 1:26, édité 3 fois
dricc
dricc
Membre

Nombre de messages : 2757
Localisation : Lille
Distinction : Altruiste - Incarnation de la Patience [Mist']
Date d'inscription : 10/08/2009

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mar 23 Aoû 2016 - 12:12
Hello ,
Houla du XP ... plus grand monde en fait, tu sais . Le GTBS n'existe pas sur MV toutefois . mais sur VX et VXAce , oui .
J'ai pratiqué le GTBS sur VXace à une époque . Son fonctionnement est vraiment trés complexe . J'avais galéré alors que je connais le ruby . Il faut dire que si tu oublies quelque chose , tu as un gros message d'erreur sans plus de détails .

Il semble qu'il te manque un paramétrage au niveau des classes d'aprés ce qu'on voit . Et en particulier sur les elements .

Si tu n'utilises pas les éléments , tu peux tout simplement mettre la ligne en commentaire et la remplacer par :
result = 100

Pour savoir ce qu'il se passe exactement , il faudrait débugguer . par exemple , ajouter avant :
p @class_id
p element_id
Mikem
Mikem
Membre

Nombre de messages : 16
Age : 25
Localisation : Alpes-Maritimes
Distinction : aucune
Date d'inscription : 15/07/2014

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mar 23 Aoû 2016 - 15:15
Merci beaucoup, Dricc, comme tu m'as dit, j'ai utilisé "débugguer" en mettant un p devant @class_id et element_id mais j'ai également fait la même chose pour la ligne 125 de la partie Game_enemy
avec p@enemy_id et p enemyelement_id, et le combat ce lance super bien, toutefois, j'ai encore un autre bug et celui-ci provient des sorts, vois-tu quand je jet un sort sur un enemy avec n'importe quels personnages, un message sur fond noir apparaît également : [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP Messag12.

Voici aussi le script concerné : https://i.servimg.com/u/f35/18/94/11/56/bugscr11.png

Je pense qu'il faut que "j'ajoute" le sort dans les paramètre du script ? Non ? Et si c'est cela comment dois-je m'y prendre ?

Ps : Oui je ne sais pas scripter.

Merci BEAUCOUP pour ton aide

Cordialement

Mikem
dricc
dricc
Membre

Nombre de messages : 2757
Localisation : Lille
Distinction : Altruiste - Incarnation de la Patience [Mist']
Date d'inscription : 10/08/2009

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mar 23 Aoû 2016 - 16:47
ça se lance ???
"p @class_id", c'est censé écrire la valeur de la variable class_id dans la console (ah oui , j'ai oublié de te dire de l'activer) . C'est pas censé corriger le bug Smile
le "p" est une abréviation pour "print" .

Cette nouvelle erreur , je ne la comprends pas trop .
Mais oui : vérifie ton setup . A chaque fois que tu vois "GTBS::" dans le code , c'est que ça fait reference à un setup dans un script plus haut .plus haut , je vois GTBS::move_range par exemple . ça , c'est le nombre de cases qu'un personnage peux parcourir . ça fonctionne par classe .
DrakeRoxas
DrakeRoxas
Membre

Nombre de messages : 44
Age : 26
Distinction : aucune
Date d'inscription : 23/07/2016

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mar 23 Aoû 2016 - 16:57
En fait il te manque des attributs, donc tu vas dans BDD, Système, et tu ajoute les attributs manquants (Pense à remettre le script d'origine, avant la modif de Dricc)

PS : Sous XP le "p Machin" ne marche pas, c'est print(Machin), et ça ouvre une fenêtre, il n'y a pas de console (bien + chiant que VX Ace :p)

EDIT : Vérifie aussi que tu joue bien avec/contre des héros/ennemis qui existe
Mikem
Mikem
Membre

Nombre de messages : 16
Age : 25
Localisation : Alpes-Maritimes
Distinction : aucune
Date d'inscription : 15/07/2014

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mar 23 Aoû 2016 - 19:09
Autant pour moi j'ai toujours le même problème pour Game_Actor à la ligne 28, hélas je ne trouve pas de solution à mon problème ^^' (devrais-je abandonner ? Non jamais tant que je le peut, je dois continuer !!)

J'ai toutefois fait ce que Dricc et DrakeRoxas mon dit mais hélas le message apparaît toujours quand je jet un sort sur un enemy...

En espérant trouver une solution je remercie la communauté pour son aide et sa patience !! x)

Cordialement

Mikem
Mikem
Mikem
Membre

Nombre de messages : 16
Age : 25
Localisation : Alpes-Maritimes
Distinction : aucune
Date d'inscription : 15/07/2014

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mar 23 Aoû 2016 - 22:48
Alors, officiellement le problème de ce topique est réglé, comme, également concernant la ligne 28 de Game_Actor ne s'affiche plus en écran noir et je peux lancer les sort, j'ai modifié la ligne 114 de Game_Actor par : result = 100 j'ai fais de même pour Game_Enemy et quand je jet des sorts ça fonctionne super bien (je me répète là...) xD Sauf que maintenant le léger petite bug qu'il y a c'est que, quand je gagne un combat, après le combat, l'avatar donc le charcter disparaît littéralement de la map, il ne reste que l’ennemi qui est visible et les PNJ. Si toutefois quelqu'un sait comment faire je lui en serait gré !!

Merci à vous

Cordialement

Mikem
dricc
dricc
Membre

Nombre de messages : 2757
Localisation : Lille
Distinction : Altruiste - Incarnation de la Patience [Mist']
Date d'inscription : 10/08/2009

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mer 24 Aoû 2016 - 9:52
Alors , tu as surement du paramétrage qui manque .
A l'époque , gubid (qui avait traduit le GTBS en français) avait fait des vidéos :

sa chaine :
https://www.youtube.com/user/gubid/search?query=GTBS
Et par exemple :
https://www.youtube.com/watch?v=BRh_NQ7Sp-I

Bon , c'est du VX , là . Il devrait y avoir qq différences avec ta version .

PS : Tu devrais remettre les anciennes lignes Wink result=100 , ça ignore les effets des éléments , c'est pas terrible .
Mikem
Mikem
Membre

Nombre de messages : 16
Age : 25
Localisation : Alpes-Maritimes
Distinction : aucune
Date d'inscription : 15/07/2014

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

le Mer 24 Aoû 2016 - 10:52
Je viens de remettre les lignes de script par défaut à la place de result = 100 mais je ne peux plus lancer de combat ni envoyer des sorts.

Il y a toujours un problème avec ce script hélas...

Merci Dricc pour les liens youtube je vais voir si cela peut aidé à mon problème Wink

Cordialement

Mikem
Contenu sponsorisé

Résolu Re: [Résolu] Bug sur Script TBS (Tactical Battle System) RMXP

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum