Partagez
Aller en bas
avatar
Natlink722
Apprenti Mineur
Apprenti Mineur
Nombre de messages : 13
Age : 19
Localisation : France - Doubs
Capacités : assez bon
Distinction : aucune
Date d'inscription : 16/10/2015

[Résolu] Bug ou Probleme venant de moi? Event

le Dim 1 Nov 2015 - 8:07
Bonsoir! J'viens poster ce message car j'ai un petit problème sous MV...
Enfin je sais pas si c'est un problème ou juste moi qui suit mauvais, mais j'ai deux fonctions que je n'arrive strictement pas à utiliser...

Pour commencer : Les interrupteurs locaux ne fonctionne tous simplement pas, par exemple
- Si joueur possede objet : Clef,
- Interupteur local A = On

et dans un autre event :
- Si interupteur local A = On,
- Afficher message...

Ceci par exemple ne fonctionne pas, il ne se passe rien quand j'active l’événement censé détecter si je possède la clef ou non...

et j'ai un autre problème avec les "Page d'event" enfin je suppose que c'est plus une mauvaise utilisation ou compréhension de ma part
Mais quand je met par exemple sur la première page une suite d'action censé déplacer l’événement vers le héro, et sur la seconde page, si le joueur touche l’événement, alors afficher un message, ça me fait un mic-mac pas possible :
L’événement n'a plus de skin, les actions ne sont pas prisent en compte, il ne se passe rien, ou alors pas dans le bon sens etc...
Alors si quelqu'un aurait une solution à me proposer, je lui en serrait grandement reconnaissant !


Dernière édition par Natlink722 le Dim 1 Nov 2015 - 8:39, édité 1 fois
avatar
Hermoni
Garde du Roi
Garde du Roi
Nombre de messages : 912
Localisation : Quelque part entre la cuisine et le clavier.
Capacités : bon
Distinction : - Hermomo' le Chat. Noir et sarcastique mais chat tout de même é_è [Shamu' :3]

Date d'inscription : 07/09/2015

Re: [Résolu] Bug ou Probleme venant de moi? Event

le Dim 1 Nov 2015 - 8:15
Les interrupteurs locaux (comme leur nom l'indique) ne fonctionnent que pour et dans un seul et même event.
L'interrupteur local A d'un 1er event sera pas le même que l'interrupteur local A d'un 2eme event.
Pour ça que ça marche pas. Faut passer par les interrupteurs classiques si tu dois faire dans divers events.


Pour les pages d'event il y a un ordre à respecter pour que ça fonctionne en fonction des conditions (et ça s'arrête dès que les conditions d'une page sont valides). Normalement ça regarde de droite à gauche si j'me trompe pas. Ca verifie les conditions, si sont pas valides ça regarde la suivante.
avatar
Natlink722
Apprenti Mineur
Apprenti Mineur
Nombre de messages : 13
Age : 19
Localisation : France - Doubs
Capacités : assez bon
Distinction : aucune
Date d'inscription : 16/10/2015

Re: [Résolu] Bug ou Probleme venant de moi? Event

le Dim 1 Nov 2015 - 8:39
Haaaaaaaaa !
Tu viens d'éclairer deux grosse cases d'ombre dans mon esprit !
Merci bien l'ami !
Contenu sponsorisé

Re: [Résolu] Bug ou Probleme venant de moi? Event

Revenir en haut
Permission de ce forum:
Vous pouvez répondre aux sujets dans ce forum