Partagez
Aller en bas
avatar
CrashBoomBen
Membre

Nombre de messages : 4
Distinction : aucune
Date d'inscription : 26/01/2015

Problème avec battleback script. (VX)

le Mar 27 Jan 2015 - 1:40
Bonjour a tous,

J'ai un problème avec ce script ici: http://www.rpgmakervx-fr.com/t16117-battleback



Le script ne marche pas pour moi. Neutral C'est à dire, ça marche pour un seul fond, le deuxième donne une erreur:
Je reçois l'erreur suivante: " 'Cache' line 75 (Typeerror) can't convert nil into string "

Dans 'cache', en ligne 75, il y a simplement:

Code:
 #--------------------------------------------------------------------------
  # * Load Bitmap
  #--------------------------------------------------------------------------
  def self.load_bitmap(folder_name, filename, hue = 0)
    @cache = {} if @cache == nil

  path = folder_name + filename
 
Code:
if not @cache.include?(path) or @cache[path].disposed?
      if filename.empty?
        @cache[path] = Bitmap.new(32, 32)
      else
        @cache[path] = Bitmap.new(path)
      end
    end
    if hue == 0
      return @cache[path]
    else
      key = [path, hue]
      if not @cache.include?(key) or @cache[key].disposed?
        @cache[key] = @cache[path].clone
        @cache[key].hue_change(hue)
      end
      return @cache[key]
    end
  end
end

J'ai essayé de trouver une solution moi même mais car je ne sais pas beaucoup sur le scripting, je n'ai pas trouvé une solution. Sad
avatar
Ti-Max
Membre

Nombre de messages : 1013
Localisation : Canada/Québec
Distinction : Poisson 2018 [Amal']
Date d'inscription : 02/09/2009

Re: Problème avec battleback script. (VX)

le Mar 27 Jan 2015 - 2:41
Tes fichiers images tu les as mis où ? Car dans le script il disent qu'il doivent d'être dans le dossier 'Battle Fond' mais il en n'a pas. Tu dois donc le créer et mettre tes images de fond dans ce dossiers.

Sinon, je ne vois pas d'où viendrait ton erreur, moi il fonctionne bien.
avatar
CrashBoomBen
Membre

Nombre de messages : 4
Distinction : aucune
Date d'inscription : 26/01/2015

Re: Problème avec battleback script. (VX)

le Mar 27 Jan 2015 - 3:46
J'ai creé un dossier "Battle Fond" et mis mes images dedans! Néanmoins, ça marche pas. Peut-être c'est pq j'ai edition 1.02?

Edit: Pas de soucis mes gens, c'est résolu! VX ne montre pas le juste Map ID ici. C'est ça qu' était le problème. J'ai découvert la solution en faisant une teste sans d'autres scripts, sur un nouveau jeu.


Dernière édition par CrashBoomBen le Mar 27 Jan 2015 - 4:24, édité 1 fois (Raison : résolu)
avatar
Ti-Max
Membre

Nombre de messages : 1013
Localisation : Canada/Québec
Distinction : Poisson 2018 [Amal']
Date d'inscription : 02/09/2009

Re: Problème avec battleback script. (VX)

le Mer 28 Jan 2015 - 1:14
Tant mieux, c'est toujours bon de faire des test dans un nouveau projet pour voir les incompatibilité. ^^
Contenu sponsorisé

Re: Problème avec battleback script. (VX)

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum