Partagez
Aller en bas
ashtrail
Membre

Nombre de messages : 12
Localisation : Paris
Distinction : aucune
Date d'inscription : 29/04/2013

Mon jeu laggue!

le Lun 6 Mai 2013 - 13:49
Bonjour et merci de vous interessez à mon problème,
Voila mon jeu (en test en tous cas) laggue grave. J'avais mis en script Ace Shop Option -> http://yanflychannel.wordpress.com/rmvxa/menu-scripts/ace-shop-options/
ainsi que Kread-EX’s Synthesis Shop( http://grimoirecastle.wordpress.com/2011/12/12/synthesis-shop/ ) pour lequel j'ai du installer aussi Alchemic Synthesis ( http://grimoirecastle.wordpress.com/?s=Alchemic+Synthesis ) et Traits Namer( http://grimoirecastle.wordpress.com/rgss3-scripts/dependencies/traits-namer/ ).

Ça en fait des liens... Bref quand je lance mon test(juste après avoir mis les scripts) ça me dit erreur: dans Alchemic Synthesis. Après avoir regarder la ligne en question et n'avoir strictement rien compris je me dis "bon j'efface pour l'instant je trouverais une solutions plus tard". J'efface donc et ça me dit "Synthesis Shop ne marche pas sans Alchemic Synthesis" et le test commence. Et là ça laggue. Affolé je décide de virer Synthesis Shop et même Traits Namer (qui ne me sert à rien tout seul) pensant que c'est de leur faute. Je relance le test et ça relaggue (un peu moins fort). Je décide de virer Ace Shop Option (ah au fait si vous pensez que c'est peut-être du à leur position par rapport aux autres scripts c'est pas ça vu que j'ai fait attention) mais même après ça laggue. Je l'ai ensuite remis et revirer -> aucun changement. J'ai eteins mon ordi et réessayé plus tard (ça lagguais mais presque pas). Puis j'ai rééteins puis réallumer mais ça laggue toujours. Voila ou j'en suis. Merci de m'aider car je suis vraiment dans le caca (ça laggue un max là).

Merci d'avoir pris le temps de lire. J'espère que quelqu'un pourra m'aider...

EDIT: C'est peut-être aussi à cause de mon ordi, ou alors dû au fait que j'ai rajouté pas mal d'items, compétences etc. On sait jamais ça peut peut-être vous aider...
avatar
Spytje
Administrateur

Nombre de messages : 5899
Localisation : La terre
Distinction : Spiraliste [Korn']
Forestia : Projet du mois juillet 2014
Papy Pulkigrat [Yama']
Date d'inscription : 16/03/2008

Re: Mon jeu laggue!

le Lun 6 Mai 2013 - 14:43
Peus-tu upload une version cryptée de ton projet pour que je puisse test sur mon ordi.

Je ne vois pas d'ou viens le problème comme ça, les scripts que tu utilises n'ont aucune raison de faire lagguer ton jeu.

Ce sont les seuls scripts que tu as ajouté dans ton projet ?
ashtrail
Membre

Nombre de messages : 12
Localisation : Paris
Distinction : aucune
Date d'inscription : 29/04/2013

Re: Mon jeu laggue!

le Mar 7 Mai 2013 - 13:18
Non ce ne sont pas les seul scripts mais tous viennent de Yanfly donc pas de souci normalement. Et oui je veux bien t'envoyer une version cryptée (en revanche comment je fais?)
avatar
Spytje
Administrateur

Nombre de messages : 5899
Localisation : La terre
Distinction : Spiraliste [Korn']
Forestia : Projet du mois juillet 2014
Papy Pulkigrat [Yama']
Date d'inscription : 16/03/2008

Re: Mon jeu laggue!

le Mar 7 Mai 2013 - 19:00
Peux-tu me donner la liste de tes scripts en entier avant s\'il te plaît ?

ashtrail
Membre

Nombre de messages : 12
Localisation : Paris
Distinction : aucune
Date d'inscription : 29/04/2013

Re: Mon jeu laggue!

le Mer 8 Mai 2013 - 14:43
OK c'est parti et dans l'ordre (punaise ça va être long....) tu les trouveras tous ici http://yanflychannel.wordpress.com/rmvxa/ :
-Ace Core Engine
-Ace Message System v1.05
-Adjust Limits v1.00
-Ace Battle Engine v1.22
-Battle Engine Add-On: Elemental Popups v1.00
-Enemy Target Info v1.02
-Combat Log Display v1.02
-Element Absorb v1.01
-Element Reflect v1.01
-Extra Drops v1.01
-State Animations v1.00
-Victory Aftermath v1.03
-Field State Effects v1.00
-Weapon Attack Replace v1.01
-Force Move Tiles v1.00
-Move Restrict Region v1.03
-Slippery Tiles v1.00
-Debug Extension v1.01

Oui c'est long, je l'avais dit. Mais ce type est un génie!

Ah sinon j'ai ça aussi mais je l'avais avant dès le début et ça ne m'a jamais fais bugger (comme les autres d'ailleurs je ne pense pas que le problème vienne des scripts mais bon...)


Code:
#==============================================================================
# ** Window Time
#------------------------------------------------------------------------------
#  Display Game Time
#==============================================================================
class Window_PlayTime < Window_Base
  def initialize(x, y)
        super(x, y, 160, 60)
        self.contents.font.bold = true
        self.contents.font.size = 25
        self.contents.font.color = normal_color
        refresh
  end
  #--------------------------------------------------------------------------
  # * Refresh
  #--------------------------------------------------------------------------
  def refresh
        self.contents.clear
        @total_sec = Graphics.frame_count / Graphics.frame_rate
        hour = @total_sec / 60 / 60
        min = @total_sec / 60 % 60
        sec = @total_sec % 60
        ptime = sprintf("%02d:%02d:%02d", hour, min, sec)
        self.contents.draw_text(4, 0, contents.width - 8, contents.height - 4, "Temps : " + ptime, 2)
  end
 
  def update
        super
        if Graphics.frame_count / Graphics.frame_rate != @total_sec
          refresh
        end
  end
end
 
class Scene_Menu < Scene_MenuBase
 
  #--------------------------------------------------------------------------
  # ● start
  #--------------------------------------------------------------------------
  alias flip_playtime_start start
  def start
        flip_playtime_start
        create_playtime_window
  end
 
  #--------------------------------------------------------------------------
  # ● create Playtime Window
  #--------------------------------------------------------------------------
  def create_playtime_window
        @playtime_window = Window_PlayTime.new(0, 308)
  end
end

Voila voila... En tous cas merci de prendre de ton temps pour m'aider.
avatar
Spytje
Administrateur

Nombre de messages : 5899
Localisation : La terre
Distinction : Spiraliste [Korn']
Forestia : Projet du mois juillet 2014
Papy Pulkigrat [Yama']
Date d'inscription : 16/03/2008

Re: Mon jeu laggue!

le Dim 12 Mai 2013 - 17:11
Je ne vois pas comme cella d'ou vient le soucis et je ne pense pas que cella vienne des scripts.

Pourrais-tu m'envoyer un lien avec ton projet décrypter pour que je puisses chercher d'ou vient ce lag ?
avatar
Lunri
Membre

Nombre de messages : 673
Age : 28
Distinction : aucune
Date d'inscription : 31/07/2011

Re: Mon jeu laggue!

le Dim 12 Mai 2013 - 18:52
Les évents aussi peuvent faire laguer ton jeu si tu les utilises pas correctement/ si y en à trop sur une même map/ trop d'events qui marchent en processus parallèles etc.

Donc utilise la fonction "attendre" dans tes évents et lis des tutos pour essayer de les optimiser.
ashtrail
Membre

Nombre de messages : 12
Localisation : Paris
Distinction : aucune
Date d'inscription : 29/04/2013

Re: Mon jeu laggue!

le Mer 15 Mai 2013 - 16:51
Ok merci pour les conseil. Sinon spywaretof je fais ça. Je te l'envoi par MP.
avatar
dodo44650
Membre

Nombre de messages : 88
Age : 19
Localisation : La où je suis ! et j'y reste !
Distinction : aucune
Date d'inscription : 02/03/2013

Re: Mon jeu laggue!

le Mer 15 Mai 2013 - 18:08
Rajout Résolu dans ton sujet (clique sur éditer au dessus de ton premier message et change le titre )
ashtrail
Membre

Nombre de messages : 12
Localisation : Paris
Distinction : aucune
Date d'inscription : 29/04/2013

Re: Mon jeu laggue!

le Sam 18 Mai 2013 - 11:16
Oui mais techniquement il n'est pas encore résolu voila la raison pour laquelle je ne l'ai pas fait...
avatar
dodo44650
Membre

Nombre de messages : 88
Age : 19
Localisation : La où je suis ! et j'y reste !
Distinction : aucune
Date d'inscription : 02/03/2013

Re: Mon jeu laggue!

le Sam 18 Mai 2013 - 11:29
:sors:
avatar
Alexdream
Membre

Nombre de messages : 1400
Age : 29
Localisation : Rodez
Date d'inscription : 02/03/2008
http://alexdream.canalblog.com/

Re: Mon jeu laggue!

le Sam 18 Mai 2013 - 12:34
diminue la taille de t'es map aux besoins coupe les grandes en plus petite et sa devrait déja aller mieux.
ashtrail
Membre

Nombre de messages : 12
Localisation : Paris
Distinction : aucune
Date d'inscription : 29/04/2013

Re: Mon jeu laggue!

le Ven 24 Mai 2013 - 16:42
OK mais j'ai pas de maps énormes à part une ou deux (mais t'as raison c'est peut-être ça vu que ça a buggé après la création d'une grosse map).
avatar
Korndor
Staffeux retraité

Nombre de messages : 4959
Age : 105
Localisation : Erem Vehyx
Distinction : Champion de boxe et au lit ! :O [Wax]
Être Mythique [Mister]
Papi Korndor qui a l'ostéoporose [Skillo]
Soldat Ikéa [Coco']
Un bonhomme, un vrai ! [Neresis]
Vieillard acariâtre [Didier Gustin]
Date d'inscription : 16/12/2007
http://www.rpgmakervx-fr.com/

Re: Mon jeu laggue!

le Ven 24 Mai 2013 - 17:00
@ Dodo :
Si il y a besoin de prévenir quelqu'un pour la règle du [Résolu], on s'en chargera (le staff).

Merci Wink
Contenu sponsorisé

Re: Mon jeu laggue!

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum