Partagez
Aller en bas
avatar
Ewaldar
Membre

Nombre de messages : 1387
Age : 24
Localisation : Suisse
Distinction : aucune
Date d'inscription : 29/12/2011
http://ewaldar.wixsite.com/les-ames-perdues

[Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 22:24
Bonjour à tous,
Nature du problème : Message d'erreur dans un script
Explication complète : J'ai insérer dans mon projet le script de restriction des mouvements aléatoires ou de suivie des événements de Tiroflan. Seulement, un message d'erreur apparaît et je
ne puis le résoudre. Ci-joint, un screen pouvant servir.
Screens :
Spoiler:

Je vous remercie d'avance de votre aide


Dernière édition par XtremeViper le Mar 3 Jan 2012 - 23:40, édité 1 fois
avatar
Gummy
Staffeux retraité

Nombre de messages : 2666
Age : 26
Localisation : Belgique
Distinction : Modérateur imprévisible

Papy Lolo' [Nabots Nimousse]


Date d'inscription : 27/01/2008

Re: [Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 22:35
Tu as un problème de syntaxe révélant un code incomplet. Les méthodes et certains opérateurs se terminent par un "end" et visiblement c'est ce qui pose problème ici : soit tu as des "end" en trop, soit tu en as trop peu.

Il faut vérifier le script et particulièrement à la ligne 146.
avatar
Tiroflan
Membre

Nombre de messages : 14
Age : 27
Distinction : aucune
Date d'inscription : 03/01/2012

Re: [Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 22:51
Vu qu'il marche sans problèmes chez moi, et que ce message d'erreur indique qu'il manque un "end" quelque part, ben vérifie déjà que t'as bien collé le code en entier (le dernier "end" devrait être à la ligne 152). Si c'est pas ça, euh, tu peux me recopier le code directement depuis ton projet ?
avatar
Ewaldar
Membre

Nombre de messages : 1387
Age : 24
Localisation : Suisse
Distinction : aucune
Date d'inscription : 29/12/2011
http://ewaldar.wixsite.com/les-ames-perdues

Re: [Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 22:57
Si je rajoute des end, le problème reste identique, si je supprime ce end, il me met ceci :

Spoiler:

Que dois-je faire ?


EDIT : PROBLÈME RÉSOLU


Dernière édition par XtremeViper le Mar 3 Jan 2012 - 23:38, édité 1 fois
avatar
Tiroflan
Membre

Nombre de messages : 14
Age : 27
Distinction : aucune
Date d'inscription : 03/01/2012

Re: [Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 23:08
Hmm, t'as du effacer la ligne
Code:
class Game_Event < Game_Character

Que je ne vois pas dans ce que tu me colles.

Je comprend pas trop pourquoi ça t'a tout collé sur une seule ligne, mais ce que je te conseille, c'est de jeter le code actuel, vu qu'il manque des lignes maintenant, de reprendre celui du topic, et de le coller d'abord dans le bloc-notes si ça met encore une fois tout en une seule ligne.
avatar
Ewaldar
Membre

Nombre de messages : 1387
Age : 24
Localisation : Suisse
Distinction : aucune
Date d'inscription : 29/12/2011
http://ewaldar.wixsite.com/les-ames-perdues

Re: [Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 23:15
J'ai dû la supprimer en mettant en forme ! Seulement, j'ai beau collé ce script n'importe où, il se met
sur une ligne, donc il va falloir que je fasse gaffe.

Dès que j'ai remis en forme, je test et je vous dis si c'est résolu ou non
avatar
Tiroflan
Membre

Nombre de messages : 14
Age : 27
Distinction : aucune
Date d'inscription : 03/01/2012

Re: [Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 23:24
Voilà un lien avec le code, ce sera peut être plus simple.
avatar
Ewaldar
Membre

Nombre de messages : 1387
Age : 24
Localisation : Suisse
Distinction : aucune
Date d'inscription : 29/12/2011
http://ewaldar.wixsite.com/les-ames-perdues

Re: [Scripts]Message d'erreur[résolu]

le Mar 3 Jan 2012 - 23:39
Merci beaucoup, cela fonctionne parfaitement ! Il me manquait facile 10 lignes... affraid

Le topic pourra être déplacé en résolu !
Contenu sponsorisé

Re: [Scripts]Message d'erreur[résolu]

Revenir en haut
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum